mirror of
https://github.com/luxfi/wallet.git
synced 2026-10-30 15:13:19 +00:00
typescript 7.0.2 is the native compiler and exports no JavaScript API, so ts-node in apps/mobile and tsup in pkgs/chains cannot read it. It comes in aliased as tsgo and does the typechecking; typescript moves to 6.0.3 for the tools. apps/web calls the alias by path because pnpm cannot link a bin for it — both packages declare the bin name tsc. apps/extension, apps/mobile and apps/web report the same 265 diagnostics under 5.9.3, 6.0.3 and 7.0.2, so the move is compiler-neutral. The lockfile refresh that came with the install is what brings apps/web's 47 of those into view: the committed lockfile still resolved @hanzo/gui to ^7.0.0 while apps/web has asked for ^8.3.1 for some time, so pnpm install --frozen-lockfile failed outright. It now succeeds, and those 47 are a gui 8 prop-type gap, not a compiler one. Co-authored-by: Hanzo Dev <[email protected]>
46 lines
1.3 KiB
JSON
46 lines
1.3 KiB
JSON
{
|
|
"name": "@luxfi/wallet-web",
|
|
"version": "0.1.0",
|
|
"license": "GPL-3.0-or-later",
|
|
"private": true,
|
|
"type": "module",
|
|
"scripts": {
|
|
"dev": "vite",
|
|
"build": "vite build",
|
|
"preview": "vite preview",
|
|
"typecheck": "../../node_modules/tsgo/bin/tsc --noEmit",
|
|
"test": "node --import ./tools/ts-resolve.mjs --test 'src/lib/**/*.test.ts' 'src/store/**/*.test.ts' 'src/screens/dapps/**/*.test.ts'"
|
|
},
|
|
"dependencies": {
|
|
"@hanzo/gui": "^8.3.1",
|
|
"@hanzo/iam": "^0.21.18",
|
|
"@luxfi/logo": "^1.0.9",
|
|
"@luxfi/wallet-analytics": "workspace:^",
|
|
"@luxfi/wallet-brand": "workspace:^",
|
|
"@luxwallet/chains": "^0.1.0",
|
|
"@noble/curves": "^1.6.0",
|
|
"@noble/hashes": "^1.7.1",
|
|
"@noble/post-quantum": "0.6.1",
|
|
"@scure/bip32": "^1.5.0",
|
|
"@scure/bip39": "^1.4.0",
|
|
"@solana/web3.js": "^1.92.0",
|
|
"@tanstack/react-query": "^5.90.0",
|
|
"@walletconnect/sign-client": "^2.21.0",
|
|
"@walletconnect/utils": "^2.21.0",
|
|
"qrcode.react": "^4.1.0",
|
|
"react": "19.2.5",
|
|
"react-dom": "19.2.5",
|
|
"react-router-dom": "7.5.0",
|
|
"viem": "^2.30.0",
|
|
"wagmi": "^2.15.0",
|
|
"zustand": "^5.0.0"
|
|
},
|
|
"devDependencies": {
|
|
"@types/react": "^19.0.0",
|
|
"@types/react-dom": "^19.0.0",
|
|
"@vitejs/plugin-react": "^4.4.1",
|
|
"typescript": "6.0.3",
|
|
"vite": "8.0.8"
|
|
}
|
|
}
|